Spec-Zone.ru › MySQL 5.7

16.2.2.3 Startup Options and Replication Channels

This section describes startup options which are impacted by the addition of replication channels.

The following startup settings must be configured correctly to use multi-source replication.

  • relay_log_info_repository.

    This must be set to TABLE. If this variable is set to FILE, attempting to add more sources to a replica fails with .

  • master_info_repository

    This must be set to TABLE. If this variable is set to FILE, attempting to add more sources to a replica fails with .

The following startup options now affect all channels in a replication topology.

  • --log-slave-updates

    All transactions received by the replica (even from multiple sources) are written in the binary log.

  • --relay-log-purge

    When set, each channel purges its own relay log automatically.

  • --slave_transaction_retries

    Applier threads of all channels retry transactions.

  • --skip-slave-start

    No replication threads start on any channels.

  • --slave-skip-errors

    Execution continues and errors are skipped for all channels.

The values set for the following startup options apply on each channel; since these are mysqld startup options, they are applied on every channel.

  • --max-relay-log-size=size

    Maximum size of the individual relay log file for each channel; after reaching this limit, the file is rotated.

  • --relay-log-space-limit=size

    Upper limit for the total size of all relay logs combined, for each individual channel. For N channels, the combined size of these logs is limited to relay_log_space_limit * N.

  • --slave-parallel-workers=value

    Number of worker threads per channel.

  • slave_checkpoint_group

    Waiting time by an I/O thread for each source.

  • --relay-log-index=filename

    Base name for each channel's relay log index file. See Section 16.2.2.4, “Replication Channel Naming Conventions”.

  • --relay-log=filename

    Denotes the base name of each channel's relay log file. See Section 16.2.2.4, “Replication Channel Naming Conventions”.

  • --slave_net-timeout=N

    This value is set per channel, so that each channel waits for N seconds to check for a broken connection.

  • --slave-skip-counter=N

    This value is set per channel, so that each channel skips N events from its source.

© 2025 Oracle
Licensed under the GPLv2 License.
https://docs.oracle.com/cd/E17952_01/mysql-5.7-en/channels-startup-options.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API