16.2.2.3 Startup Options and Replication Channels
This section describes startup options which are impacted by the addition of replication channels.
The following startup settings must be configured correctly to use multi-source replication.
-
This must be set to
TABLE. If this variable is set toFILE, attempting to add more sources to a replica fails with . -
This must be set to
TABLE. If this variable is set toFILE, attempting to add more sources to a replica fails with .
The following startup options now affect all channels in a replication topology.
-
All transactions received by the replica (even from multiple sources) are written in the binary log.
-
When set, each channel purges its own relay log automatically.
-
Applier threads of all channels retry transactions.
-
No replication threads start on any channels.
-
Execution continues and errors are skipped for all channels.
The values set for the following startup options apply on each channel; since these are mysqld startup options, they are applied on every channel.
-
--max-relay-log-size=sizeMaximum size of the individual relay log file for each channel; after reaching this limit, the file is rotated.
-
--relay-log-space-limit=sizeUpper limit for the total size of all relay logs combined, for each individual channel. For
Nchannels, the combined size of these logs is limited torelay_log_space_limit *.N -
--slave-parallel-workers=valueNumber of worker threads per channel.
-
Waiting time by an I/O thread for each source.
-
--relay-log-index=filenameBase name for each channel's relay log index file. See Section 16.2.2.4, “Replication Channel Naming Conventions”.
-
--relay-log=filenameDenotes the base name of each channel's relay log file. See Section 16.2.2.4, “Replication Channel Naming Conventions”.
-
--slave_net-timeout=NThis value is set per channel, so that each channel waits for
Nseconds to check for a broken connection. -
--slave-skip-counter=NThis value is set per channel, so that each channel skips
Nevents from its source.
© 2025 Oracle
Licensed under the GPLv2 License.