Spec-Zone.ru › OpenJDK 25

Package java.util.zip

package java.util.zip
Provides classes for reading and writing the standard ZIP and GZIP file formats. Also includes classes for compressing and decompressing data using the DEFLATE compression algorithm, which is used by the ZIP and GZIP file formats. Additionally, there are utility classes for computing the CRC-32, CRC-32C and Adler-32 checksums of arbitrary input streams.

Package Specification

  • Info-ZIP Application Note 970311 - a detailed description of the Info-ZIP format upon which the java.util.zip classes are based.
  • An implementation may optionally support the ZIP64(tm) format extensions defined by the PKWARE ZIP File Format Specification. The ZIP64(tm) format extensions are used to overcome the size limitations of the original ZIP format.
  • APPENDIX D of PKWARE ZIP File Format Specification - Language Encoding Flag to encode ZIP entry filename and comment fields using UTF-8.
  • ZLIB Compressed Data Format Specification version 3.3 (pdf) (RFC 1950)
  • DEFLATE Compressed Data Format Specification version 1.3 (pdf) (RFC 1951)
  • GZIP file format specification version 4.3 (pdf) (RFC 1952)
  • CRC-32 checksum is described in RFC 1952 (above)
  • CRC-32C checksum is described in Internet Small Computer Systems Interface (iSCSI) (pdf) (RFC 3720)
  • Adler-32 checksum is described in RFC 1950 (above)
Since:
1.1
External Specifications
  • RFC 1950: ZLIB Compressed Data Format Specification version 3.3
  • RFC 1951: DEFLATE Compressed Data Format Specification version 1.3
  • RFC 1952: GZIP file format specification version 4.3
  • RFC 3720: Internet Small Computer Systems Interface (iSCSI)
Package Description
java.util
Contains the collections framework, some internationalization support classes, a service loader, properties, random number generation, string parsing and scanning classes, base64 encoding and decoding, a bit array, and several miscellaneous utility classes.
Class Description
Adler32
A class that can be used to compute the Adler-32 checksum of a data stream.
CheckedInputStream
An input stream that also maintains a checksum of the data being read.
CheckedOutputStream
An output stream that also maintains a checksum of the data being written.
Checksum
An interface representing a data checksum.
CRC32
A class that can be used to compute the CRC-32 of a data stream.
CRC32C
A class that can be used to compute the CRC-32C of a data stream.
DataFormatException
Signals that a data format error has occurred.
Deflater
This class provides support for general purpose compression using the popular ZLIB compression library.
DeflaterInputStream
Implements an input stream filter for compressing data in the "deflate" compression format.
DeflaterOutputStream
This class implements an output stream filter for compressing data in the "deflate" compression format.
GZIPInputStream
This class implements a stream filter for reading compressed data in the GZIP file format.
GZIPOutputStream
This class implements a stream filter for writing compressed data in the GZIP file format.
Inflater
This class provides support for general purpose decompression using the popular ZLIB compression library.
InflaterInputStream
This class implements a stream filter for uncompressing data in the "deflate" compression format.
InflaterOutputStream
Implements an output stream filter for uncompressing data stored in the "deflate" compression format.
ZipEntry
This class is used to represent a ZIP file entry.
ZipError Deprecated, for removal: This API element is subject to removal in a future version.
ZipError is no longer used and is obsolete.
ZipException
Signals that a ZIP exception of some sort has occurred.
ZipFile
This class is used to read entries from a ZIP file.
ZipInputStream
An input stream for reading compressed and uncompressed ZIP file entries from a stream of bytes in the ZIP file format.
ZipOutputStream
This class implements an output stream filter for writing files in the ZIP file format.

Report a bug or suggest an enhancement
For further API reference and developer documentation see the Java SE Documentation, which contains more detailed, developer-targeted descriptions with conceptual overviews, definitions of terms, workarounds, and working code examples. Other versions.
Java is a trademark or registered trademark of Oracle and/or its affiliates in the US and other countries.
Copyright © 1993, 2025, Oracle and/or its affiliates, 500 Oracle Parkway, Redwood Shores, CA 94065 USA.
All rights reserved. Use is subject to license terms and the documentation redistribution policy.

© 1993, 2025, Oracle and/or its affiliates. All rights reserved.
Documentation extracted from Debian's OpenJDK Development Kit package.
Licensed under the GNU General Public License, version 2, with the Classpath Exception.
Various third party code in OpenJDK is licensed under different licenses (see Debian package).
Java and OpenJDK are trademarks or registered trademarks of Oracle and/or its affiliates.
https://docs.oracle.com/en/java/javase/25/docs/api/java.base/java/util/zip/package-summary.html

Spec-Zone.ru

Настройки Оффлайн Что нового Помощь О нас
Spec-Zone .ru
спецификации, руководства, описания, API